Xcode4.3導入は慎重になったほうがいいかも

最近調子にのってXcode4.3をインストールしたのはいいものの、コマンドラインツールがインストールされなくなったり、gccがllvm-gccになったりしていて結構困りました。特に自分でオープンソースのソフトウェアをビルドしようとするとカオス。頼みの綱MacPortsのドキュメントにも次のように書かれていて、対応にしばらく時間がかかりそうな状態。

MacPorts stops working after installing Xcode 4.3

Due to incompatible changes in Xcode 4.3, it cannot be used by MacPorts at present. Many of the issues should be able to be fixed in a MacPorts update, but some may need to be resolved by Apple in an Xcode update. Until then, on Lion, please use Xcode 4.1 through 4.2.1 inclusive.

AppleによるXcodeの修正が必要らしく、それがすむまで、Xcode 4.1〜4.2.1を使っていてほしいということです。iOSアプリやMacアプリの開発で今すぐ最新版Xcodeを入れる必要がないなら、4.2.1あたりでとめといたほうがいいかもしれません。

スポンサーリンク