PHP 5.3のサポート期限が迫ってきているのでPukiWikiユーザーは気にした方がいいかも

PHP 5.3のサポート期限が今月末(2013年3月31日)に迫ってきているみたいですね(slashdot日本版マイナビニュース)。

PukiWikiガーPHP5.4 対応ガー

自分には関係ないと思ってスルーしていたのですが、 「src's wiki」でも利用している、PukiWikiが PHP 5.4に対応していない事に気がつきました。

設置済みのPukiWikiをこのまま使い続ける分には問題ないとして(セキュリティ上のリスクはあるかもしれません)、新規サーバーに設定したい場合、そこがPHP5.4環境だと困ったことになりそうです。

一応非公式パッチは存在する様子

軽くググってみたところ以下の非公式パッチを発見しました。

未確認ですが PHP 5.4で pukiwiki 1.4.7を動かす場合上記パッチを当てればうまく動くかもしれません。

そもそもPukiWikiの開発が完全に停滞しているので、他のWikiエンジンを探す時期なのかもしれませんが…。いいのがあれば連絡ください(汗。

スポンサーリンク