【悲報】「Ruby 1.8.7は引退しました」

Ruby logo R

Ruby 1.8.7 は引退しました」というラノベ小説風タイトルのニュースがRuby公式サイトに投稿され、Ruby 1.8.7の引退が勧告されています。

記事の内容は以下のように始まる、

すでに大半の方は ruby 1.9.x か 2.0.0 をお使いのことと思います。 (もしまだならそうしてください。) かつて、1.4.x、1.6.x、1.8.x といったバージョンがありました。 これらは MRI と呼ばれており、ruby 1.0 直系の子孫です。 当時最先端の ruby として matz により 1.8.0 はリリースされ、1.8.7 はその血統の最後の一人となりました。

ruby 1.0直系の子孫である、Ruby 1.8.7の使用中止を求めるもの。

記事の日本語が妙にたどたどしいのは英語を日本語に翻訳したからでしょうか。とりあえず1.8系先輩、お疲れ様でした。

スポンサーリンク