Readline 6.3 に対応した「Ruby 2.1.2リリース

Ruby logo R

プログラミング言語Rubyの最新版「Ruby 2.1.2」がリリースされています(最新ニュースChangeLog)。

このバージョン 2.1.2 では、「Hash#reject の不具合の修正」、「Readline 6.3 との組み合わせで発生するビルドエラーの修正」、「拡張ライブラリ psych に同梱される libyaml のバージョン更新」や、その他の不具合の修正が行われているということ。

パッチ無しでコンパイル可能に

最近、Macで(?)Ruby 2.X.Xをインストールしようとするとビルドエラーが発生して困っていた人も多かったかもしれませんが、2.1.2では解決されています。

$ RUBY_CONFIGURE_OPTS="--with-openssl-dir=/opt/local --with-readline-dir=/opt/local" rbenv install 2.1.2
Downloading ruby-2.1.2.tar.gz...
-> http://dqw8nmjcqpjn7.cloudfront.net/a5b5c83565f8bd954ee522bd287d2ca1
Installing ruby-2.1.2...
Installed ruby-2.1.2 to /Users/sora/.rbenv/versions/2.1.2

↑試しにrbenv 2.1.2 を入れてみたらすんなり入りました。不具合修正バージョンなので、2.1.1ユーザーは早めに最新バージョンにバージョンアップしておいたほうがよさそうです。

スポンサーリンク