【Tips】「Podcasts」は、iOSでのみご利用いただけます。という謎のエラーを解決する

2016 06 24 220439

ひさびさにiTunesを使ってiOS用のアプリを更新しようと思い立ち「すべてのAppを更新」してみたところ上の画像のようなエラーが表示されてしまいました。

「Podcasts」は、iOSでのみご利用いただけます。
「Podcasts」を入手するには、iOSデバイスのApp Storeで検索します。

エラーメッセージをそのまま解釈すれば、iOSデバイス上のApp Storeアプリで、Podcastsアプリを更新すれば問題が解決できるように思えますがこれは正しくありません。なぜならiOS 9の段階ではPodcastsアプリはiOS組み込みアプリで、App Storeでは提供されていないアプリだからです(iOS 10では単体提供される計画があるようですが)。

検索してみるとどうやらこれはiTunesの不具合の模様。

Q: can't update Podcasts or Find My Friends in iTunes sync
【iTunes】「友達を探す」「Podcast」のアップデートが表示されるが「iOSでのみご利用頂けます」の件

Hello, Apple will need to sort this out but... You can fix this now. Just delete Find My Friends and Podcasts apps from your iTunes library on your PC or Mac. The Find My Friends and Podcasts apps will remain on all iOS devices. Friends and Podcast will update just as they should on your iOS devices as well... Other apps will update as needed in iTunes and will sync as they should. All Fixed...

Podcastsアプリ以外にも「友達を探す」などでも発生しているとのこと。Appleが問題を修正するまで右クリックからアプリを削除するしかないようです。iTunes上で削除してもiOSデバイス上のPodcastsアプリは削除されません。

2016 06 24 220825

内部的にiOS 10への対応を進めているのかもしれませんが、まだ正式リリースされていないのにこの状態はちょっと…。早期の修正を期待です。

スポンサーリンク